解决xhost: unable to open display ""

Linux系统
178
linux
linux 举报
05月28日 11:42
解决xhost: unable to open display ""

实用技巧:在Linux下设置xhost方法步骤

第一步:用root登陆linux,启动vnc服务;

第二步:根据vnc起来的端口,设置export DISPLAY=localhost:1(1表示vnc在第一个tty上启动的),vnc的启动信息见附件1;

第三步:执行xhost +,并且提示“access control disabled, clients can connect from any host”才正确。

linux下的操作日志如下:

[root@localhost ~]# vncserver

New 'localhost:1 (root)' desktop is localhost:1

Starting applications specified in /root/.vnc/xstartupLog file is /root/.vnc/localhost:1.log

[root@localhost ~]# export DISPLAY=localhost:1

[root@localhost ~]# xhost +

access control disabled, clients can connect from any host 

在设置xhost时,出现了unable的问题。使用上诉方法就可以搞定。

大家在使用客户端连接linux的时候,secureCRT是个非常棒的工具,但是由于不支持图形模式,在一些需要图形界面的时候就很麻烦,其实有个比较简单的解决办法,就是使用xmanager的passive.

准备:secureCRT和xmanager安装

步骤:1.启动xmanager的passive        2.在secureCRT中执行以下的命令

           export DISPLAY=192.168.25.1:0.0  ip地址是本机的客户端地址        3.测试           xclock           如果在passive的窗口出现一个图形化的钟表,就ok,然后执行netca等图形化安装配置命令均可。



倒序看帖 只看楼主
推广信息